Linux errors.. [closed]

Found a bug in KAC? Post it here.
Post Reply
EclipseGSX
Posts: 10
Joined: Tue Jun 09, 2009 5:21 pm
Location: Seattle, WA
Contact:

Linux errors.. [closed]

Post by EclipseGSX » Fri Feb 18, 2011 12:59 am

So I agreed to help a friend of mine out by resurrecting his server of awesomeness, and he decided to remake his server as a linux box. I figured, hey, this should be no issues. I even talked him up to the coolness of KAC...

...but now I'm having an error :(

vitals:
Ubuntu Linux Server x64
Counter-Strike Source (linux server binary, orangebox, VAC-secured)
SourceMod 1.3.6
MetaMod:Source 1.8.5
Socket 3.0.1 (as found here) -- loaded and working
SDKHooks 1.3 (as found here) -- loaded and working
Kigen AC (non beta) as found here

Once I load KigenAC, everything works as expected on the console side... until these start showing up every 5 seconds:

Code: Select all

L 02/17/2011 - 22:43:39: [SM] Native "SocketConnect" reported: Invalid handle: 0
L 02/17/2011 - 22:43:39: [SM] Displaying call stack trace for plugin "kigen-ac-pub.smx":
L 02/17/2011 - 22:43:39: [SM]   [0]  Line 126, kigenac/network.sp::Network_Timer()
Now, as a sidenote, I looked into the scripting directory, and there was no kigenac sub-dir in there (as it is not included as part of the download anymore)... I'm thinking that this is most likely the cause of this, but I have no method of creating the file that it is requesting.
Last edited by EclipseGSX on Fri Feb 18, 2011 3:36 pm, edited 1 time in total.

User avatar
Kigen
Site Admin
Posts: 1494
Joined: Sat Jun 07, 2008 11:08 am
Location: Right behind you....
Contact:

Re: Linux errors..

Post by Kigen » Fri Feb 18, 2011 2:22 am

The file referenced is a script file. Its not needed to run the plugin. Its just debug info so I know where the error occurred.

I'll look into it.
Image

User avatar
Kigen
Site Admin
Posts: 1494
Joined: Sat Jun 07, 2008 11:08 am
Location: Right behind you....
Contact:

Re: Linux errors..

Post by Kigen » Fri Feb 18, 2011 2:54 am

This is very odd. Something is preventing the creation of Sockets on that machine.
Image

EclipseGSX
Posts: 10
Joined: Tue Jun 09, 2009 5:21 pm
Location: Seattle, WA
Contact:

Re: Linux errors..

Post by EclipseGSX » Fri Feb 18, 2011 3:54 am

redacted....


edit: So, after a restart of the service it has magically started to work... :?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest